The issue impacting the delivery of SMS OTP notifications required for contract validation has been resolved. Service functionality has been fully restored, and all regions are now operating normally. We have implemented the necessary corrective actions with our upstream provider to ensure continued stability and do not expect further impact.
Posted Mar 15, 2026 - 12:57 WET
Investigating
We are currently investigating an issue that is preventing the delivery of SMS notifications containing OTP codes required to validate new contracts. As a result, users are unable to complete the contract finalization process on the Subscription Form in Portugal, the Netherlands, and Italy. We are working with our SMS provider to identify the root cause and restore normal delivery as quickly as possible.
Posted Mar 15, 2026 - 12:41 WET
This incident affected: Subscription (Portugal, Netherlands, Italy).