Completed
The scheduled maintenance has been completed.
Posted Mar 10, 2026 - 12:07 WET
Update
The maintenance will keep going for at least 5 more hours.
Posted Mar 10, 2026 - 11:15 WET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 10, 2026 - 10:07 WET
Scheduled
Although there was previously a message sent stating the maintenance was over, we continue working on the platform and expect to do so for the next 2 hours.
We will keep you updated regarding the availability of the platform.
We apologise for any inconvenience this may cause.
Posted Mar 10, 2026 - 10:06 WET
This scheduled maintenance affected: Merchant Space (Portugal, Spain, Belgium, Netherlands, Romania, Italy), Selfcare (Portugal, Spain, Belgium, Netherlands, Romania, Italy), Subscription (Portugal, Spain, Belgium, Netherlands, Romania, Italy), Back Office (Portugal, Spain, Belgium, Netherlands, Romania, Italy), and API (Portugal, Spain, Belgium, Netherlands, Romania, Italy).